无法升级WebPack并使其与ESM一起使用

我正在使用webpack.config.babel.js在项目上使用webpack,以便我可以使用esm Systax

我有这个babel配置

"babel": {
  "presets": [
    [
      "@babel/preset-env",
      {
        "targets": {
          "browsers": [">1%", "last 4 versions", "not ie < 9"]
        },
        "useBuiltIns": "usage",
        "debug": false,
        "corejs": 3
      }
    ],
    "@babel/preset-react"
  ]
}

我在包装上的任何地方都没有"type": "modules"

在`package.json上使用此脚本

"dev": "webpack serve --env --mode=development --config webpack/webpack.config.babel.js",

并让其他此软件包:

"@babel/core": "~7.12.3",
"@babel/eslint-parser": "^7.21.3",
"@babel/preset-env": "~7.12.1",
"@babel/preset-react": "~7.12.1",
"@babel/register": "~7.12.1",
"webpack": "^5.75.0",
"webpack-bundle-analyzer": "~4.1.0",
"webpack-cli": "^4.9.2",
"webpack-dev-server": "~3.11.0",
"webpack-merge": "~5.3.0",

我在用 node v21.6.2

所有这些都很好,我可以在WebPack上使用import

但是,如果我尝试将WebPack升级到更高版本,则所有分手都无法读取ESM语法,无论我做什么要成为一团糟,因为互联网上没有一篇文章,它对我有用,所以我最终将所有内容混合在一起。但这永远无法使用。

0 个回答

  • 3 浏览
  • Álvaro 提出于 2024-03-02 03:58:04

相似问题