有什么方法可以修复软件包锁。JSONLOCKFILEVERVERION,因此NPM使用特定格式?

如果两个不同的开发人员使用不同版本的节点(12/15)&npm(6/7)在最初使用package-lock.json "lockfileVersion": 1]的项目中,当使用NPM 7X安装新软件包时,似乎[package-lock.json ]使用"lockfileVersion": 2重新创建。

这似乎是使用NPM V6的开发人员的问题,因为它试图与lockfileVersion 2合作,但最终会产生新的差异。

npm警告读取shrinkwrap此版本的NPM与lockfileversion@1兼容,但是package-lock.json是为lockfileversion@2生成的。我会尽力而为!

有什么方法可以指定npm 使用"lockfileVersion": 1的较新版本?还是我们只需要在同一版本的npm上获得所有开发人员?

0 个回答

  • 299158 浏览
  • Ben 提出于 2020-11-13 00:24:24

相似问题